Increased Error Rates: Timeouts
Incident Report for Ontraport
Postmortem

We identified a rare failure mode that can happen during our routine code release process. We fixed the issue, and are placing additional monitoring on this, as well as updating the release process to catch the failure mode sooner and prevent it from manifesting.

Posted May 19, 2022 - 12:27 PDT

Resolved
Our servers started reporting an increased rate of timeout related errors. This would have shown as non-responsive content/pages in various areas of our platform. These failures would have impacted potentially 15-20% of web requests.
Posted Apr 21, 2022 - 12:00 PDT