Email Delivery Delays
Incident Report for Ontraport
Resolved
We have not observed any abnormal delays since applying the last round of fixes, and emails are flowing normally.
Posted Nov 23, 2022 - 07:50 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 22, 2022 - 14:47 PST
Update
The queues and overall delivery latency remain in an acceptable state. As before, we will leave this issue open and continue monitoring for abnormalities in delivery times.
Posted Nov 22, 2022 - 11:39 PST
Update
The recent changes made to appear to have addressed the bulk of the latency. While some emails may still experience latency, the majority of emails are flowing normally.

As before, we will continue to monitor this ongoing issue and remedy as needed.
Posted Nov 22, 2022 - 09:30 PST
Update
The underlying issues causing the queuing have resurfaced. We are mitigating on our end where possible, while the issues external to Ontraport's systems are being addressed.
Posted Nov 22, 2022 - 07:47 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2022 - 16:48 PST
Monitoring
Email queues have been drained and are flowing normally. They returned to normal several hours ago, but we are going to continue to monitor this issue over the next several days.
Posted Nov 21, 2022 - 14:41 PST
Identified
We have identified the issue and are working to mitigate. The queues are decreasing in size and the bulk of email is being processed as received. While there will continue to be some delays, they should be reducing over time until it returns to normal.
Posted Nov 21, 2022 - 11:05 PST
Investigating
We are currently investigating abnormally large queue times within our email processing systems. This issue can result in delays in email sends.
Posted Nov 21, 2022 - 10:24 PST
This incident affected: Backend Services (Email Delivery).