Bad Code Push
Incident Report for Ontraport
Postmortem

As we continue to create and add new capacity and features to our infrastructure, we routinely integrate completely new and tested systems. In this case, one of our production-ready test systems received a bad code push which resulted in some strange in-app behaviors for some portion of the logged in community.

The servers were immediately removed from rotation, and any potential bad code was purged from various production pathways. We have since updated our integration process to catch some additional areas where old could could be blended into production pathways.

Posted May 19, 2022 - 13:09 PDT

Resolved
A bad code push on a production ready testing system resulted in some strange in-app behaviors for some users. "Automations" changing back to the legacy name of "Campaigns", for instance.
Posted Apr 16, 2022 - 05:10 PDT