Email Delivery Latency

Incident Report for Ontraport

Resolved

This issue has been resolved.
Posted Oct 24, 2025 - 18:17 PDT

Update

We are still waiting for DNS updates to fully propagate. Roughly 80% of impacted traffic has been addressed.
Posted Oct 23, 2025 - 16:09 PDT

Update

We have resolution of the issue; continued monitoring and ongoing confirmation that the fixes are fully functional are currently underway.
Posted Oct 22, 2025 - 12:38 PDT

Update

We are waiting for a resolution from a 3rd party. In the meantime, we are observing the Email Delivery systems to ensure that the impact is as minimal as possible.
Posted Oct 21, 2025 - 15:21 PDT

Monitoring

We are currently experiencing partial delays in some outbound email delivery due to a DNS issue with one of our service providers.

Email delivery may be delayed for some recipients. Affected messages are automatically retried until successful or until a 12-hour retry window expires.
Posted Oct 21, 2025 - 12:19 PDT
This incident affected: Isolated (Isolated Accounts) and Backend Services (Email Delivery).